Issue Report Wednesday February 17, 2021, 5:00 pm


We are experiencing an issue with VoIP telephone services that is affecting outbound telephone call processing. Reports of intermittent outbound call failures have been made. ITS is working diligently with SEGRA to further determine the situation and a solution. An update will be provided as soon as more information becomes available.

Updates have been made and a possible resolution to the performance issues reported by users. This issue will be closely monitored until it is determined completely resolved.