Issue Report - Internet Connectivity Issue at CCU due to Off-Campus Outage Friday November 12, 2021, 9:30 am


We are experiencing internet connectivity issues due to an off-campus outage. ITS is working with Segra and HTC to address this issue at CCU and determine when there will be a resolution to restore internet access at CCU and the off-campus outage. An update will be provided as soon as possible.

The internet service is restored.

Update: Wireless connectivity is restored. Work is in progress to restore the on campus wired network.