Issue Report Wednesday September 21, 2022, 3:15 pm


We are experiencing an issue with analog phone lines affecting alarm lines, fax lines, and elevator lines on Campus. ITS is working with provider to identify the issue.

Campus analog phone line services have been restored.

Issue believed to be related to possible fiber optic cut. Service provider technicians are still working to locate the exact location and extent to provide an estimated time-frame for repair. Updates will be provided as futher information is relayed to our team.