Issue Report Thursday February 2, 2023, 8:00 am


Reports of call quality issues have been reported on campus. ITS is working with the voice service provider to identify and resolve the root cause. Updates will be posted as they become available.

Voice services call quality issue has been resolved.

Telephone voice / call quality issues are still reported on campus. ITS has continued to work diligently with our campus telephone service provider to identify the issue.
Updates will be posted as they are available.