Issue Report - Moodle Services Monday July 22, 2024, 2:30 pm


The Office of Academic Technology is actively working with our Moodle hosting vendor to resolve connectivity issues.

UPDATE 7/22/2024: Moodle access issues are restored as of July 22 around 4:15pm.