All systems are operational.

1 year ago ·
Fixed

Fixed

1 year ago ·

Crews have completed repairs. Services have been restored.

Identified

1 year ago ·

The service provider has a team actively working to fix fiber damage related to this issue. Currenty the ETA for the repair team is 5:30pm but there is not yet an ETA on repair completion. The damage is extensive and will be time consuming. Updates will be provided as they are made available.

Identified

1 year ago ·

The service provider has a team actively working to fix fiber damage related to this issue. Currenty the ETA for the repair team is 5:30pm but there is not yet an ETA on repair completion. The damage is extensive and will be time consuming. Updates will be provided as they are made available.

Investigating

1 year ago ·

Support cases have been opened with and escalated with our phone service provider. We continue to investigate the issue to determine the root cause.

1 year ago ·

We have had reports of poor voice quality on incoming / outgoing telephone calls. We are working with the service provider to identify the root cause. Updates will be provided as they become available.

Incident UUID 2595ad21-52b8-4410-94a5-b9e35a7624e9