All systems are operational.

8 months ago ·
Fixed

Fixed

7 months ago ·

All of Perceptive Content Services were restored same day.

Fixed

8 months ago ·

All Ellucian systems have been fully restored.

8 months ago ·

We are currently experiencing issues with Ellucian Colleague, Self Service, and myCCU. ITS is actively working to restore services.

Incident UUID 71c1d569-860b-4d7f-9b3f-518de5082fe3