Some systems are experiencing issues.

Affected components

Identified
Affected Components: Telephone Services, Wired - Campus Network, Internet access and WiFi - eduroam

Identified

1 day ago

We are aware of service interruptions in Kingston Hall. Failed equipment has been identified. preparations for replacement is in the works.