All systems are operational.

Fixed

2 years ago ·

It appears the power has now been restored.

Identified

2 years ago ·

This also impacts the Tennis Complex

2 years ago ·

All services in Coastal Science Center, Atlantica Hall, Tennis and 450 Century Circle are being impacted by a power event at Coastal Science Center. Services should restore when the power is restored.

Incident UUID 94b85220-1c1c-4581-94c5-53ab5f00c4f1