All systems are operational.

1 year ago ·
Fixed

Fixed

1 year ago ·

Self Service and myCCU functionality have been fully restored. Thank you for your patience.

Investigating

1 year ago ·

In addition to Self Service, myccu.coastal.edu is also experiencing issues. We are actively working working with the vendor to resolve as soon as possible. Thanks for your understanding.

1 year ago ·

We are experiencing an issue with Self Service. ITS is aware and actively working with the vendor to restore services.

Incident UUID a22171ed-f378-4534-9d66-78c9a9b11f1f