All systems are operational.

3 years ago ·
Fixed

Fixed

3 years ago ·

Campus analog phone line services have been restored.

Investigating

3 years ago ·

Issue believed to be related to possible fiber optic cut. Service provider technicians are still working to locate the exact location and extent to provide an estimated time-frame for repair. Updates will be provided as futher information is relayed to our team.

3 years ago ·

We are experiencing an issue with analog phone lines affecting alarm lines, fax lines, and elevator lines on Campus. ITS is working with provider to identify the issue.

Incident UUID fac4e24b-e6d0-4bfe-a927-c01c4609c799