All systems are operational.

3 years ago ·
Fixed

Fixed

3 years ago ·

The previously reported issues with the T Drive are now resolved.

Identified

3 years ago ·

ITS is collaborating with the hardware vendor for support.

3 years ago ·

We are experiencing an issue with the T drive. ITS technicians are working to further determine the situation and a solution. An update will be provided as soon as possible.

Incident UUID fd89f977-fb5b-4cf3-acab-7fb6457c17fd